Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел ( сейчас прошли циклические алгоритмы, нужна и блок-схема)
Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел
( сейчас прошли циклические алгоритмы, нужна и блок-схема)
Ответ(ы) на вопрос:
var n,a,i:integer;
s:longint;
begin
writeln('введите количество чисел');
readln(n);
a:=0; s:=0;
writeln('введите числа');
for i:=1 to n do begin
readln(a);
if a>10 then s:=s+a*a;
end;
if s=0 then writeln('положительных чисел нет') else writeln(s);
end.
Не нашли ответ?
Похожие вопросы