Помогите срочно пожалуйста!! Написать программу подсчитывающую вол-во цифр в заданном числе.
Помогите срочно пожалуйста!! Написать программу подсчитывающую вол-во цифр в заданном числе.
Ответ(ы) на вопрос:
Var
i,a:integer;
ch:set of char;
n:string;
Begin
Write('Введите число ');
Readln(n);
ch:=['0'..'9'];
for i:= 1 to length(n) do
if n[i] in ch then a:=a+1;
case a of
1:Write('В числе ',a,' цифра');
2..4:Write('В числе ',a,' цифры')
else Write('В числе ',a,' цифр');
End;
End.
Не нашли ответ?
Похожие вопросы