ПОМОГИТЕ ТУРБО ПАСКАЛЬ! Факториалом числа m называется произведение натуральных чисел от 1 до m.m!=1*2*3*..*m;4!=1*2*3*4=24.Требуется написать программу, которая подсчитывает количество факториалов между N и K(включительно).ФОР...

ПОМОГИТЕ ТУРБО ПАСКАЛЬ! Факториалом числа m называется произведение натуральных чисел от 1 до m. m!=1*2*3*..*m; 4!=1*2*3*4=24. Требуется написать программу, которая подсчитывает количество факториалов между N и K(включительно). ФОРМАТ ВХОДА ДАННЫХ: На вход подается два натуральных числа N и K, записанные через пробел. (1
Гость
Ответ(ы) на вопрос:
Гость
var n,k,fact:int64; c,i:longint; Begin readln(n,k); fact:=1; i:=2;c:=0; while(fact<=k) do Begin if (fact>=n)and(fact<=k) then inc(c); fact:=fact*i; inc(i); end; writeln(c); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы