Помогитееее Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Помогитееее Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Ответ(ы) на вопрос:
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var s:=ReadInteger('n=').ToString;
if (Pos(s[1],Copy(s,2,2))>0) or (s[2]=s[3])
then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры
Не нашли ответ?
Похожие вопросы