Помогите!!!Нужно написать программы на Pascal + блок-схемы. С клавиатуры последовательно вводится n-целых чисел: 1)Сколько чисел отличаются от первого на величину а? 2)Для всех чисел,кроме 1 и последнего ,определите ,сколько из...

Помогите!!!Нужно написать программы на Pascal + блок-схемы. С клавиатуры последовательно вводится n-целых чисел: 1)Сколько чисел отличаются от первого на величину а? 2)Для всех чисел,кроме 1 и последнего ,определите ,сколько из них больше своих соседей?(слева и справа) 3)Вывести числа ,которые делятся на 3 ,но не делятся на 5.
Гость
Ответ(ы) на вопрос:
Гость
Const    n = 13; Var    a,i,C,k:integer;    M:array[1..N] of integer; Begin k:=0; Write('a = '); ReadLn(a); WriteLn('Введите целые числа'); For i:= 1 to n do     Read(M[i]); For i:= 2 to n do     if M[i]-a = M[1] then k:=k+1; WriteLn('1: k = ',k); k:=0; For i:= 2 to n-1 do     if (M[i-1]M[i+1]) then k:=k+1; WriteLn('2: k = ',k); Write('3: '); For i:= 1 to n do     if (M[i] mod 3 = 0)and(M[i] mod 5 <> 0) then Write(M[i],' ') End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы