Помогите,прошу,умоляю! Составить программу на языке програмирования Паскаль. 1) Пойдет ли сундук с соровищами со сторонами а,в,с в иллюминатор затонувшего корабля диаметром д. 2) Имеется треугольник с координатами(0,0)(5,0)(0,...
Помогите,прошу,умоляю!
Составить программу на языке програмирования Паскаль.
1) Пойдет ли сундук с соровищами со сторонами а,в,с в иллюминатор затонувшего корабля диаметром д.
2) Имеется треугольник с координатами(0,0)(5,0)(0,5). Попадает ли точка А(х,у) внутрь либо на границы этого треугольника. Ответ вывести в форме Да или Нет.
Ответ(ы) на вопрос:
var
a,b,c,d,x,y:real;
begin
Write('Введите размеры сторон сундука -> '); Readln(a,b,c);
Write('Введите диаметр иллюминатора -> '); Readln(d);
if a 3 5 3.99
Введите диаметр иллюминатора -> 5
Сундук можно вытащить
**********************
Условие попадания точки A(x,y) внутрь треугольника описывается как
[latex]\begin {cases} x\ge 0 \\ y\ge 0 \\ y\le 5-x \end {cases} \Rightarrow \ (x\ge0) \land (y\ge0) \land (y\le 5-x)[/latex]
var
x,y:real;
begin
Write('Введите координаты x и y точки -> '); Readln(x,y);
if (x>=0) and (y>=0) and (y<=5-x) then Writeln('Да')
else Writeln('Нет')
end.
Тестовое решение:
Введите координаты x и y точки -> 3 2.5
Нет
Введите координаты x и y точки -> 2.1 2.8
Да
Не нашли ответ?
Похожие вопросы