Поставлю лучший, много баллов! Напишите программу в Pascal ABC которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE...DO, а вывод - REPEAT...UNTIL (в скобках указана размерность массива):ув...
Поставлю лучший, много баллов! Напишите программу в Pascal ABC которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE...DO, а вывод - REPEAT...UNTIL (в скобках указана размерность массива):
увеличить элементы массива с четными индексами на 1 (11)
Ответ(ы) на вопрос:
var a:array[1..11] of integer;
b:integer;
begin
b:=1;
writeln('Введите элементы массива');
while (b<=11) do
begin
readln(a[b]);
if (b mod 2=0) then a[b]:=a[b]+1;
b:=b+1;
end;
b:=1;
repeat
writeln(a[b]);
b:=b+1;
until(b>11)
end.
Не нашли ответ?
Похожие вопросы