Построить блок-схему алгоритма и написать программу для решения следующей задачи. даны действительные числа x и y. Если x и y отрицательны, то уаждое значение заменить его модулем; если отрицательно только одно из них, то оба з...
Построить блок-схему алгоритма и написать программу для решения следующей задачи. даны действительные числа x и y. Если x и y отрицательны, то уаждое значение заменить его модулем; если отрицательно только одно из них, то оба значения увеличить на 0.5, в противном случае извлечь из каждого квадратный корень.
Ответ(ы) на вопрос:
var x, y:real; begin readln(x, y); if (x>0) and (y>0) then begin x:=sqrt(x); y:=sqrt(y); writeln(x,' ', y); end; if (x<0) and (y<0) then begin x:=x*(-1); y:=y*(-1); writeln(x,' ', y); end; if (x<0) or (y<0) then begin x:=x+0.5; y:=y+0.5; writeln(x,' ', y); end; end.
Не нашли ответ?
Похожие вопросы