Пожалуйста напишите мне данное задание от Program до End. (Тема "Циклы"- Pascal ABC) Написать программу, которая вычисляет сумму первых в членов ряда: 1,3,5,7... Количество суммированных членов ряда задаётся во время работы про...

Пожалуйста напишите мне данное задание от Program до End. (Тема "Циклы"- Pascal ABC) Написать программу, которая вычисляет сумму первых в членов ряда: 1,3,5,7... Количество суммированных членов ряда задаётся во время работы программы. Ниже приведен примерно рекомендуемый вид экрана во время работы программы. Вычисление частичной суммы ряда:1,3,5,7... Введите количество суммированных членов ряда ->1-5 Сумма первых 15 членов ряда равна 330.
Гость
Ответ(ы) на вопрос:
Гость
program zhn; var   i,n,sum:integer; begin   writeln('Вчисление суммы членов последовательности: 1,3,5,7...');   write('Введите количество членов для сложения:');   readln(n);   for i:=1 to n*2 do begin     if i mod 2 <> 0 then sum:=sum+i; //Проверяем что бы число было нечетным   end;   writeln('Сумма ',n,' членов прогресии = ',sum); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы