Пожалуйста, напишите программу Ввести два натуральных числа N и M . Если M больше N , то вывести M − N строк, в каждой строке выводятся числа от N до M число раз, соответствующее выводимому числу. Например, для N = 3 и M = 6...

Пожалуйста, напишите программу Ввести два натуральных числа N и M . Если M > N , то вывести M − N строк, в каждой строке выводятся числа от N до M число раз, соответствующее выводимому числу. Например, для N = 3 и M = 6: 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6
Гость
Ответ(ы) на вопрос:
Гость
var m,n,i,j:longint; begin readln(n,m); if m > n then begin for i:= n to m do begin for j:= 1 to i do begin write(i,' '); end; writeln; end; end else begin for i:= m to n do begin for j:= 1 to i do begin write(i,' '); end; writeln; end; end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы