ПОЖАЛУЙСТА, ПОМОГИТЕ!!!Ниже записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 28.var x, L, M: integ...
ПОЖАЛУЙСТА, ПОМОГИТЕ!!!
Ниже записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 28.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if M < x then begin
M:= M + (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.
Ответ(ы) на вопрос:
177: 3 цифры, M тоже = 28
Не нашли ответ?
Похожие вопросы