Пожалуйста ПОМОГИТЕ!Составьте программу для решения задач:1.Найдите произведение квадратных корней N первых натуральных чисел2.Определить делится ли сумма цифр заданного натурального числа на 7 3.Заменяет в записи натурального ...

Пожалуйста ПОМОГИТЕ! Составьте программу для решения задач: 1.Найдите произведение квадратных корней N первых натуральных чисел 2.Определить делится ли сумма цифр заданного натурального числа на 7  3.Заменяет в записи натурального числа N цифру 8 на цифру 3
Гость
Ответ(ы) на вопрос:
Гость
1. var n, i: integer; rez: real; begin rez:=1; readln(n); for i:=1 to n do rez:=rez*sqrt(i); write(rez); end. 2. var n: string; i, summa: integer; begin readln(n); for i:=1 to length(n) do summa:=summa+strtoint(n[i]); if (summa mod 7)=0 then write('Делится') else write('Не делится'); end. 3. var n: string; i, summa: integer; begin readln(n); for i:=1 to length(n) do if n[i]='8' then n[i]:='3'; write(n); end. Если возникли вопросы или ошибки в ходе работы программы, пиши в ЛС или комментарии.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы