ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции деления (Div и Mod) 2.Составьте программу делящую переменную А=100 на 3. Дел...
ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции деления (Div и Mod)
2.Составьте программу делящую переменную А=100 на 3. Деление прекратить когда остаток А будет меньше 3. Подсчитать количество вариантов деления и вынести значение на экран.
Ответ(ы) на вопрос:
1.
var s,a,b,c,d:integer;
begin
readln(s);
a:=s div 1000;
b:=s div 100 mod 10;
c:=s div 10 mod 10;
d:=s mod 10;
writeln('Тысяч ',a,' Сотен ',b,' Десятков ',c,' Единиц ',d);
end.
2.
var k,a:integer;
begin
a:=100;
while a>=3 do begin
a:=a div 3;
k:=k+1;
end;
writeln(k);
end.
Не нашли ответ?
Похожие вопросы