Привет всем, нужно написать программу не используя операторы цикла (формулой) Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью v километров в ч...

Привет всем, нужно написать программу не используя операторы цикла (формулой) Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью v километров в час. На какой отметке он остановится через t часов? Входные данные Программа получает на вход значения v и t. Если v>0, то Вася движется в положительном направлении по МКАД, если же значение v<0, то в отрицательном. Выходные данные Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася.
Гость
Ответ(ы) на вопрос:
Гость
var v,t,x:integer; begin write('v = '); readln(v); write('t = '); readln(t); x:=(109+(v*t-(v*t div 109)*109) mod 109) mod 109; writeln(x); end. Пример 1: v = 50 t = 3 41 Пример 2: v = -50 t = 3 68
Не нашли ответ?
Ответить на вопрос
Похожие вопросы