Программа в паскале.Даются 3 натуральных числа,если сумма первых двух больше нуля,определите максимальное число,в ином случае вычислите среднее арифметическое.

Программа в паскале.Даются 3 натуральных числа,если сумма первых двух больше нуля,определите максимальное число,в ином случае вычислите среднее арифметическое.
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016 var   a,b,c:integer;   r:real; begin   Writeln('Введите три числа: '); Read(a,b,c);   if a+b>0 then begin     r:=a;     if b>r then r:=b;     if c>r then r:=c     end   else r:=(a+b+c)/3;   Writeln('Результат равен ',r) end. Тестовые решения: Введите три числа: -5 8 11 Результат равен 11 Введите три числа: -3 -6 8 Результат равен -0.333333333333333
Не нашли ответ?
Ответить на вопрос
Похожие вопросы