ПРОШУ ,ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого прогр...

ПРОШУ ,ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!! Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0). Числа, следующие за числом 0, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).  Выходные данные Выведите ответ на задачу.
Гость
Ответ(ы) на вопрос:
Гость
Var A,k:integer; Begin k:=0; Repeat Read(A); k:=k+1; Until A = 0; Write(k-1) End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы