Работа в Паскаль! Пожалуйста, хелп:3 1. Составьте программу, которая находит сумму N чисел, введенных с клавиатуры. 2.Составьте программу, которая вычисляет произведение чисел от 1 до N. Значение N вводится с клавиатуры.
Работа в Паскаль! Пожалуйста, хелп:3
1. Составьте программу, которая находит сумму N чисел, введенных с клавиатуры.
2.Составьте программу, которая вычисляет произведение чисел от 1 до N. Значение N вводится с клавиатуры.
Ответ(ы) на вопрос:
Решение в приложении.
Всего доброго!
№1
var s,x,n,i:integer;
begin
s:=0;
write('Введите количество чисел: ');
readln(n);
writeln('Введите числа: ');
for i:=1 to n do
begin
readln (x);
s:=s+x
end;
writeln('Сумма чисел равна ',s);
end.
№2
var n,i,p:integer;
begin
p:=1;
write('Введите количество чисел: ');
readln(n);
for i:=1 to n do
p:=p*i;
writeln('Произведение чисел равнo ',p);
end.
Не нашли ответ?
Похожие вопросы