Ребят помогите 1.составить программу вычисления суммы нечётных чисел от 1 до 100 2.составить программу,которая находит суммуквадратов чисел от 1 до 100
Ребят помогите
1.составить программу вычисления суммы нечётных чисел от 1 до 100
2.составить программу,которая находит суммуквадратов чисел от 1 до 100
Ответ(ы) на вопрос:
Задание первое, решение на Pascal:
var
c, i, sum: integer;
begin
sum := 0;
for i := 1 to 100 do
begin
c := i mod 2;
if (c = 0) then sum := sum + i;
end;
writeln('Сумма нечётных чисел от 1 до 100 равна ', sum);
end.
Задание второе, решение на Pascal:
var
i, sum: integer;
begin
sum := 0;
for i := 1 to 100 do
begin
sum := sum + sqr(i);
end;
writeln('Сумма квадратов чисел от 1 до 100 равна ', sum);
end.
Не нашли ответ?
Похожие вопросы