Ребят, помогите очень срочно. Нужно написать программу на паскале. Вычислить среднеарифметическое четных элементов массива C(10), не меньших 10

Ребят, помогите очень срочно. Нужно написать программу на паскале. Вычислить среднеарифметическое четных элементов массива C(10), не меньших 10
Гость
Ответ(ы) на вопрос:
Гость
var c:array[1..10] of integer; SrAr:real; k, i, s:integer; begin s:=0;{Обнуляем счетчик элементов(к) и сумму(s)} k:=0; randomize; for i:=1 to 10 do {заполняем массив}  c[i]:=random(50); for i:=1 to 10 do  if (c[i] mod 2=0) and (c[i]>10) then {если элемент массива четный и больше 10 увеличиваем счетчик к, увеличиваем сумму s}     begin    k:=k+1;     s:=s+с[i];    end; SrAr:=s/k; for i:=1 to 10 do {выводим массив} write(c[i], ' '); writeln; writeln('Sr.Arifmeticheskoe=', SrAr:5:2); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы