Ребята плиз мне очень нужно ответь Составить программу, которая бы запрашивала Хнач , Хкон , шаг C и определяла сумму всех отрицательных чисел от Хнач до Хкон с шагом С (решить задачу, используя цикл с постусло-вием – repeat …...
Ребята плиз мне очень нужно ответь
Составить программу, которая бы запрашивала Хнач , Хкон , шаг C и определяла сумму всех отрицательных чисел от Хнач до Хкон с шагом С (решить задачу, используя цикл с постусло-вием – repeat … until).
Ответ(ы) на вопрос:
//Pascal ABC.NET 3.1 сборка 1256
Var
n,k,c,s,kar:real;
i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.
Пример ввода:
-3
1
1.1
Пример вывода:
-5.7
Не нашли ответ?
Похожие вопросы