РЕЬЯТ ПОМОГИТЕ СРОЧНООО Напишите программу вычисления выражения: s=1!+2!+3!+...+n! Исп
РЕЬЯТ ПОМОГИТЕ СРОЧНООО
Напишите программу вычисления выражения: s=1!+2!+3!+...+n!
Используйте функцию вычисления факториала
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913
Не нашли ответ?
Похожие вопросы