Решение задач с использованием строк 1. Составьте программу, которая: а) из слова «КОМПИЛЯТОР» составляет слова: «МОТОР», «КОМОК», «ПИЛОТ»; б) из слов «МАНДАРИН», «МОДА», «МАК» получает слово «КОМАНДОР»; в) заменяет в тексте, з...

Решение задач с использованием строк 1. Составьте программу, которая: а) из слова «КОМПИЛЯТОР» составляет слова: «МОТОР», «КОМОК», «ПИЛОТ»; б) из слов «МАНДАРИН», «МОДА», «МАК» получает слово «КОМАНДОР»; в) заменяет в тексте, заданном с клавиатуры, пробелы между словами подчеркиванием.
Гость
Ответ(ы) на вопрос:
Гость
var str, s, s1, s2, s3: string; i:integer; begin str:='ÊÎÌÏÈËßÒÎÐ'; s:=str[3]+str[2]+copy(str, 8, 3); writeln(s); s:=copy(str, 1, 3)+str[2]+str[1]; writeln(s); s:=copy(str, 4, 3)+str[2]+str[length(str)-2]; writeln(s); s1:='ÌÀÍÄÀÐÈÍ'; s2:='ÌÎÄÀ'; s3:='ÌÀÊ'; s:=copy(s3, 3, 1)+copy(s2, 2, 1)+copy(s1, 1, 4)+copy(s2, 2, 1)+copy(s1, length(s1)-2, 1); writeln(s); writeln('Vvedite stroku:'); readln(str); for i:=1 to length(str) do if str[i]=' ' then str[i]:='_'; writeln(str); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы