Решить на Паскале или Питоне, или .хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек. Входные данные:Дано число N, дал...
Решить на Паскале или Питоне, или .хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек. Входные данные:Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).
Ответ(ы) на вопрос:
var n, tmp, sum, i:integer;begin readln(n); sum := (n * (n + 1)) div 2; for i := 1 to n - 1 do begin read(tmp); sum := sum - tmp; end; writeln(sum);end.
Не нашли ответ?
Похожие вопросы