Решить программу с помощью Паскаля. В автобусе помещается 160 пассажиров, три четве

Решить программу с помощью Паскаля. В автобусе помещается 160 пассажиров, три четверти мест находятся в салонах эконом- класса и одна четверть - в салоне бизнес-класса. Стоимость билета в салоне бизнес-класса составляет x рублей, что в два раза выше стоимости в салонах эконом-класса. Определить прибыль авиакомпании, если непроданных билетов эконом-класса осталось а и непроданных билетов бизнес-класса осталось b.
Гость
Ответ(ы) на вопрос:
Гость
Летающий автобус) 1. Мест в эконом-классе 120, а в бизнес-классе 40. 2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение: 40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли. 3. Осталось рассчитать прибыль компании учитывая непроданные билеты: P = 100 - b - 0.5*a  и написать программу: var a,b:integer; begin   repeat     writeln('Введите количество непроданных билетов (a,b)');     readln(a,b);   until (a<=120) and (b<=40)and (a>=0) and (b>=0);   writeln('Прибыль компании составит ',100-b-0.5*a,'%'); end.  
Не нашли ответ?
Ответить на вопрос
Похожие вопросы