Решите, пожалуйста!!!Ниже записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 28.var x, L, M: integer...
Решите, пожалуйста!!!
Ниже
записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а
потом 28.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if M < x then begin
M:= M + (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.
Ответ: 177
Мне надо решение.
Ответ(ы) на вопрос:
Алгоритм проходит в цикле со счетчиком L по каждому разряду введенного числа Х, начиная с младших. Очередная цифра выделяется, удаваивается и полученные значения суммируются в переменной М до тех пор, пока составленное из оставшихся цифр число Х превышает M.
По условию L=3, следовательно число Х - трехзначное.
28 - это сумма удвоений, следовательно, она получена путем сложения цифр, которые в сумме дают 28/2, т.е. 14.
Исходное трехзначное число в общем виде может быть записано, как 100*a+10*b+c, тогда a+b+c=14, где b и c - целые числа от 0 до 9, а - целое число от 1 до 9.
Минимальное число, дающее в сумме 14, это 149. Но на первом шаге М получится равным 18 (9*2), и на следующем шаге оставшиеся от 149 цифры 1 и 4 дадут число 14, которое меньше М, что прекратит накопление суммы в М. Таким же образом не подходит число 158. Для числа 167 в первом проходе (число 7) получим М=14, во втором (число 6) М=14+12=26. А на третьем проходе мы получаем число 1 и накопления не происходит. То же будет и с числами 176, 185, 194. Следовательно, старший разряд числа не должен участвовать в формировании суммы и условие надо поменять на b+c=14. Но 14=9+5=8+6=7+7.
Минимальные трехзначные числа, составленные их этих цифр. это 159, 168 и 177.
Число 159 не подходит (2*9=18 > 15), 168 тоже не подходит (2*8=16 = 16) - с обоими накопление прекращается после первой цифры. Число 177 дает M=14, затем 17>14 и к М добавляется еще 14, давая в сумме 28. Далее 1<28, накопление прекращено, результат получен.
Итак, Х=177
Рассмотрим цикл, число шагов которого зависит от изменения переменной x:
while x > 0 do
begin
...
x:= x div 10;
end;
Т. к. оператор div оставляет только целую часть от деления, то при делении на 10 это равносильно отсечению последней цифры. Из приведенного цикла видно, что на каждом шаге от десятичной записи x отсекается последняя цифра до тех пор, пока все цифры не будут отсечены, то есть x не станет равно 0; поэтому цикл выполняется столько раз, сколько цифр в десятичной записи введенного числа, при этом число L столько же раз увеличивается на 1.
Следовательно, конечное значение L совпадает с числом цифр в x. Для того, чтобы L стало L=3, x должно быть трёхзначным.
Теперь рассмотрим оператор изменения M:
if M < x then
begin
M:= M + (x mod 10) * 2;
end;
Оператор mod оставляет только остаток от деления, при делении на 10 это последняя цифра x.
Таким образом М есть сумма удвоенных цифр числа x, которые принимают чётные значения от 0 до 18.
Для получения наименьшего x положим первую цифру x(1) = 1, она не даст вклад на третьем шаге цикла, потому что не будет выполняться условие M < x, а для того, чтобы сумма удвоенных цифр была равна 28, вторая и треться цифры должны быть больше нуля. Сделаем цифру x(3) максимально воможной, чтобы уменьшить вторую цифру и достичь минимума:
x(3) = 9, тогда 9 * 2 = 18, а x(2) = (28 - 18) / 2 = 5, но тогда не выполняется условие M < x (18 > 15) и значение 28 не достигнется.
x(3) = 8, тогда 8 * 2 = 16, а x(2) = (28 - 16) / 2 = 6, условие M < x не выполняется (16 = 16) и значение 28 не достигнется.
x(3) = 7, тогда 7 * 2 = 14, а x(2) = (28 - 14) / 2 = 7, M < x (14 < 17) и значение 28 достигaется.
Окончательно находим наименьшее число x: 177.
Не нашли ответ?
Похожие вопросы