С 1. Составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t больше 1часа,  тогда вычисляем скорость, иначе путь. Каждую строку программы, прокомментировать. Входные данные t=2 часа   

С 1. Составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t>1часа,  тогда вычисляем скорость, иначе путь. Каждую строку программы, прокомментировать. Входные данные t=2 часа    
Гость
Ответ(ы) на вопрос:
Гость
Алгоритм: Начало Ввод t Если t>1 часа, то начать выполнение операторов ввод S; V=S/t; вывод V закончить выполнение операторов иначе начать выполнение операторов ввод V; S=Vt; вывод S; закончить выполнение операторов Var S,V,t:integer; begin read(t); if t>1 then begin read(s); v:=s/t; writeln('Скорость=',v); end else begin read(v); s:=v*t; writeln('Расстояние=',s); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы