С клавиатуры вводятся два натуральных числа N и K (0 меньше N меньше =K меньше =200000). Требуется написать программу, которая находит сумму простых чисел, расположенных между N и K(включая эти числа). Пример входных данных: 2...
С клавиатуры вводятся два натуральных числа N и K (0
Ответ(ы) на вопрос:
var
simple: array[1..10000] of integer;
i, j, a, b, simple_n, s: integer;
is_simple: boolean;
begin
read(a, b);
for i := 2 to b do begin
is_simple := true;
for j := 1 to simple_n do
is_simple := is_simple and (i mod simple[j] <> 0);
if is_simple then begin
simple_n := simple_n + 1;
simple[simple_n] := i;
writeln(i);
if i >= a then s := s + i;
end;
end;
writeln(s);
end.
Не нашли ответ?
Похожие вопросы