Сделать на Pascal.Составить программу для вычисления функции, заданой графиком:
Сделать на Pascal.Составить программу для вычисления функции, заданой графиком:
Ответ(ы) на вопрос:
var y,xn,xk,s:real;
begin
readln(s,xn,xk);//s-шаг функции xn и xk - интервал иксов, в котором мы рассматриваем функцию
writeln('x',' ','y');
while xn
var x,y:real;
begin
write('x = ');
readln(x);
if (x<-4)or(x>4)
then writeln('Функция не определена')
else begin
if x<0
then y:=0
else if x<2 then y:=x*x
else y:=4;
writeln('Y = ',y);
end;
end.
Пример:
x = 1.5
Y = 2.25
Не нашли ответ?
Похожие вопросы