Семьдесят два балла за простое задание! Сделайте по-нормальному, пожалуйста. Написать программу для вычисления корней квадратного уравнения: ax^2+bc+c=0.

Семьдесят два балла за простое задание! Сделайте по-нормальному, пожалуйста.  Написать программу для вычисления корней квадратного уравнения: ax^2+bc+c=0.
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,d,x1,x2:real; begin writeln('Введите коэффициент a'); readln(a); writeln('Введите коэффициент b'); readln(b); writeln('Введите коэффициент c'); readln(c); d:=sqr(b)-4*a*c; if d>0 then  begin x1:= ((-1)*b+sqrt(d))/(2*a); x2:=((-1)*b-sqrt(d))/(2*a); writeln('x1=',x1,' x2=',x2); end else if d=0 then begin x1:= ((-1)*b)/(2*a); writeln('x=',x1); end else writeln('Корней нет'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы