Сколько чисел Фибоначчи, меньших 32000, являются простыми (первое простое число 2).Написать программу в паскале.(Ответ 8).

Сколько чисел Фибоначчи, меньших 32000, являются простыми (первое простое число 2).Написать программу в паскале.(Ответ 8).
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.NET 3.1 сборка 1219 function fibonachi(i:integer):integer; begin if i=0 then fibonachi:=0 else if i=1 then fibonachi:=1 else fibonachi:=fibonachi(i-1)+fibonachi(i-2); end; Var i,j,k:integer; b:boolean; begin i:=1; while fibonachi(i)<32000 do begin b:=false; for j:=2 to i div 2 do if i mod j=0 then b:=true; if (b=false) and (fibonachi(i)>=2) then inc(k); inc(i); end; writeln(k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы