Составить алгоритм и написать программу для вычисления факториала числа. Факториал числа обозначается n!, произносится эн факториа́л) — произведение всех натуральных чисел от 1 до n включительно: n ! = 1 ⋅ 2 ⋅ ...n. 0!=1. Приме...
Составить алгоритм и написать программу для вычисления факториала числа.
Факториал числа обозначается n!, произносится эн факториа́л) — произведение всех натуральных чисел от 1 до n включительно: n ! = 1 ⋅ 2 ⋅ ...n. 0!=1.
Пример: 4! = 1*2*3*4 = 24.
Выполнить задание двумя способами (цикл с предусловием и с фиксированым числом повторений). Все переменные целочисленные.
Ответ(ы) на вопрос:
Гость
var n,f,i:integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=2 to n do f:=f*i;
writeln(n,'! = ',f);
end.
Пример:
n = 6
6! = 720
Не нашли ответ?
Похожие вопросы