Составить блок-схему и написать программу на языке PascalABC.NET. 1. Даны действительные положительные числа x, y, z. Выяснить, существует ли треугольник с длинами сторон x, y, z. 2. Даны три действительных числа. Выбрать из ни...
Составить блок-схему и написать программу на языке PascalABC.NET.
1. Даны действительные положительные числа x, y, z. Выяснить, существует ли треугольник с длинами сторон x, y, z.
2. Даны три действительных числа. Выбрать из них те, которые принадлежат интервалу (1, 3).
Ответ(ы) на вопрос:
Гость
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x
Программа:
var x, y, z: real;
begin
writeln('Введите стороны треугольника x, y, z: ');
read(x, y, z);
if (x + y > z) and (x + z > y) and (y + z > x)
then writeln('Треугольник существует')
else writeln('Треугольник не существует');
end.
2. Думаю, здесь излишни объяснения.
Программа:
var x, y, z: real;
begin
writeln('Введите три числа: ');
read(x, y, z);
writeln('В интервале (1; 3) лежат числа: ');
if (x > 1) and (x < 3) then writeln(x);
if (y > 1) and (y < 3) then writeln(y);
if (z > 1) and (z < 3) then writeln(z);
end.
Блок-схемы в приложении:
Не нашли ответ?
Похожие вопросы