Составить блок схему и написать программу Задача: Ввести 10 значений в переменную Z . Найти и выдать на экран количество введеных нулей .
Составить блок схему и написать программу
Задача: Ввести 10 значений в переменную Z . Найти и выдать на экран количество введеных нулей
.
Ответ(ы) на вопрос:
var
i,k,z:integer;
begin
k:=0;
Write('Введите 10 целых чисел: ');
for i:=1 to 10 do
begin Read(z); if z=0 then Inc(k) end;
Writeln('Количество введенных нулей равно ',k)
end.
Тестовое решение:
Введите 10 целых чисел: 6 -5 0 4 -8 0 3 1 -2 0
Количество введенных нулей равно 3
Блок схема во вложении.
Не нашли ответ?
Похожие вопросы