Составить блок-схему и написать программу:Дано натуральное число. Найдите число десятков в его десятичной записи ( то есть вторую справа цифру его десятичной записи)
Составить блок-схему и написать программу:
Дано натуральное число. Найдите число десятков в его десятичной записи ( то есть вторую справа цифру его десятичной записи)
Ответ(ы) на вопрос:
program P1;
var
a, n:longint;
begin
readln(n);
a:=(n mod 100);
a:=(a div 10);
writeln(a);
end.
тип переменной longint означает натуральное число , просто более большее
Не нашли ответ?
Похожие вопросы