Составить программу для решения задачи: Дана строка. Проверить правильность написания слов с ЖИ-ШИ. Если слово написано неправильно,то исправить его.

Составить программу для решения задачи: Дана строка. Проверить правильность написания слов с ЖИ-ШИ. Если слово написано неправильно,то исправить его.
Гость
Ответ(ы) на вопрос:
Гость
var a:string; i:longint; begin readln(a); for i := 2 to length(a) do begin if (a[i] = 'ы') then if (a[i-1] = 'ж') or (a[i-1] = 'ш') then a[i] := 'и'; end; writeln(a); end.
Гость
var s:string; p1,p2:integer;  begin writeln('Введите слово:'); readln(s); p1:=pos('жы',s); p2:=pos('шы',s); if (p1=0)and(p2=0) then writeln('Ошибок не замечено.'); if p1>0  then  begin  delete(s,p1,2);  insert('жи',s,p1);  writeln('Слово написано с ошибкой.');  writeln('Правильное написание - ',s);  end; if p2>0  then  begin   delete(s,p2,2);  insert('ши',s,p2);  writeln('Слово написано с ошибкой.');  writeln('Правильное написание - ',s);  end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы