Составить программу для вычисления значений функции F(x) на отрезке [а, b] с шагом h(через цикл while ). Результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функц...

Составить программу для вычисления значений функции F(x) на отрезке [а, b] с шагом h(через цикл while ). Результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции.   F(x)=2tg(x/2)+1
Гость
Ответ(ы) на вопрос:
Гость
#include #include using namespace std; int main () { setlocale (0,"russian"); float a,b,h,F,x; cout << "Промежуток:\nот "; cin >> a; cout << "до "; cin >> b; cout << "Шаг: "; cin >> h; x=a; do { F=2*tan(x/2)+1; cout << "x=" << x << '\t' << "F(x)=" << F << endl;   // \t - символ табуляции x+=h; if (x==0)     //на ноль делить нельзя, поэтому, если x=0, то мы       x+=h;    // перескакиваем к следующему аргументу } while (x<=b); system ("PAUSE"); return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы