Составить программу для вычисления значения функции F(x)=x*cos(1/x)+2 на отрезке [a,b] с шагом h. результаты представить в виде таблицы (1-ый столбец - значения аргумента, 2- ой -значение функции).
Составить программу для вычисления значения функции F(x)=x*cos(1/x)+2 на отрезке [a,b] с шагом h. результаты представить в виде таблицы (1-ый столбец - значения аргумента, 2- ой -значение функции).
Ответ(ы) на вопрос:
const
n = 10;
var
a,b,h,x: real;
begin
writeln('a , b , h =');
read(a, b, h);
x := a - h;
writeln('x':n, ' | ', 'y':n);
repeat
x := x + h;
writeln(x:n:3, ' | ', (x * cos(1 / x) + 2):n:3);
until x >= b;
end.
Не нашли ответ?
Похожие вопросы