Составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа

Составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа
Гость
Ответ(ы) на вопрос:
Гость
using System; using System.Collections.Generic; using System.Linq; using System.Text; namespace ConsoleApplication4 {     class Program     {         static void Main(string[] args)         {             bool result = false;             Console.WriteLine("Введи строку");             string str = Console.ReadLine();             for (int i = 0; i < str.Length - 1; i++)             {                 if (str.Substring(i, 1) == str.Substring(i + 1, 1))                 {                     result = true;                     break;                 }             }             if (result == true)                 Console.WriteLine("Да, встречаются");             else                 Console.WriteLine("Нет, не встречаются");             Console.ReadKey();         }     } }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы