Составить программу, которая подсчитывает общее количество общих количественных целых пятизначных чисел, которые удовлетворяют условиям: a) abcde - пятизначное число b) a, b, c, d - разные цифры c) ac-ce=a-b+c+d+e d) e - че...

Составить программу, которая подсчитывает общее количество общих количественных целых пятизначных чисел, которые удовлетворяют условиям: a) abcde - пятизначное число b) a, b, c, d - разные цифры c) ac-ce=a-b+c+d+e d) e - четное число В ответе запишите только число.
Гость
Ответ(ы) на вопрос:
Гость
Текст программы (Pascal) var   a,b,c,d,e:byte;   k:integer; begin   k:=0;   for a:=1 to 9 do begin     for b:=0 to 9 do       if b<>a then begin         for c:=0 to 9 do           if (c<>a) and (c<>b) then begin             for d:=0 to 9 do               if (d<>a) and (d<>b) and (d<>c) then begin                 e:=0;                 repeat                   if a*c-c*e=a-b+c+d+e then Inc(k);                   e:=e+2                 until e<9               end           end       end   end;   Writeln(k) end. Тестовое решение: 190
Не нашли ответ?
Ответить на вопрос
Похожие вопросы