Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые обладают тем свойством, что число, образованное первыми двумя цифрами, будучи умноженным на среднюю циф...
Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые обладают тем свойством, что число, образованное первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число, образованное последними двумя цифрами.
Ответ(ы) на вопрос:
var
a, b, c, d, e, n: integer;
begin
n := 0;
for a := 1 to 9 do
for b := 0 to 9 do
for c := 1 to 9 do
for d := 0 to 9 do
for e := 0 to 9 do
if (10 * a + b) * c = (10 * d + e) then n := n + 1;
Writeln(n)
end.
Тестовое решение:
196
Не нашли ответ?
Похожие вопросы