Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку

Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку
Гость
Ответ(ы) на вопрос:
Гость
var a,count:longint; s:string; begin writeln('введите строку'); count:=0; read(s); while pos('жы',s)>0 do  begin  inc(count);  a:=pos('жы',s);  delete(s,a,2);  insert('жи',s,a) end; while pos('шы',s)>0 do  begin  inc(count);  a:=pos('шы',s);  delete(s,a,2);  insert('ши',s,a) end; writeln(s); writeln('всего ошибок: ',count) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы