Составить программу которая рассчитывает высоты проведенной к гипотенузе прямоугольного треугольника если известны его катеты значения катетов запрашиваются и вводятся с клавиатуры. Пожалуй ста помагите срочно
Составить программу которая рассчитывает высоты проведенной к гипотенузе прямоугольного треугольника если известны его катеты значения катетов запрашиваются и вводятся с клавиатуры. Пожалуй ста помагите срочно
Ответ(ы) на вопрос:
Гость
Высоту можно определить по известной формуле (если проблемы с этим - см. Интернет или задайте вопрос в Геометрии, чтобы формулу вывели):
[latex]\displaystyle h:= \frac{ab}{ \sqrt {a^2+b^2}} [/latex], где a,b - катеты
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
var a,b:real;
Write('Введите катеты через пробел: '); Read(a,b);
Writeln('h=',a*b/sqrt(a*a+b*b))
end.
Не нашли ответ?
Похожие вопросы