Составить программу, которая вычисляет произведение сомножителей: (1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)… Вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6. В ответе написать коли...
Составить программу, которая вычисляет произведение сомножителей:
(1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)…
Вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6.
В ответе написать количество сомножителей для данного вычисления. В ответе указать только число, например, 15
Ответ(ы) на вопрос:
var i, ans : integer;
pr : real;
begin
i := 1;
pr := 1;
ans := 0;
while (pr <= 3.6) do begin
pr *= (1 + 1 / (i * i));
i := i + 1;
ans := ans + 1;
end;
writeln(ans);
end.
48 сомножителей
Не нашли ответ?
Похожие вопросы