Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа
Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа
Ответ(ы) на вопрос:
Гость
program yourname;
var a,b,c,d:integer;
begin
writeln('Введите ваше число!');
writeln('В каждую ячейку можно вписать только однозначное число.');
writeln('Пример: Число 2341 вводится так: 2 3 4 1 .');
readln(a,b,c,d);
writeln('Ваше число: ' , a,b,c,d);
writeln('Произведение цифр вашего числа: ' , a*b*c*d);
writeln('Сумма цифр вашего числа: ' , a+b+c+d);
end.
Не нашли ответ?
Похожие вопросы