Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответ(ы) на вопрос:
var a:integer;
begin
writeln('a=');
readln(a);
if (a>0) then writeln('cislo polojitelinoe',a/2) else
writeln('cislo otritatelinoie',sqr(a));
readln;
end.
Не нашли ответ?
Похожие вопросы