Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг. Определить количество самых дешевых книг(с одинаковой минимальной ценой)
Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг. Определить количество самых дешевых книг(с одинаковой минимальной ценой)
Ответ(ы) на вопрос:
var mas:array of integer; min,kol ,j, i,n:integer;
begin
Randomize; min:=0;kol:=0;
write('n:' );
readln(n);
setlength(mas,length(mas)+n);///динамический массив вы можете заменить на статический
For i:= 0 to high(mas) do
mas[i]:=Random(50);
min:=mas[0];
for j:=0 to high(mas) do//ищем минимальную ценну
if min>mas[j] then
min:=mas[j] ;
For i:= 0 to high(mas) do
if min=mas[i] then//ищем количество книг с минимальной ценой
inc(kol);
write('kolvo min ',kol);
readln;
end.
Не нашли ответ?
Похожие вопросы