Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Составить программу на языке паскаль:
Две точки задаются своими координатами. Определите, какая из них находится дальше от:
начала координат;
окружности заданного радиуса с центром в начале координат.
Ответ(ы) на вопрос:
program gt;
var x1,y1,x2,y2,r:real;
begin
readln(x1,y1,x2,y2);
readln(r);
if((sqr(x1)+sqr(y1))<(sqr(x2)+sqr(y2)))then writeln('Pervaya')else
writeln('2-raya');
if(abs(sqrt(sqr(x1)+sqr(y1))-r)
Не нашли ответ?
Похожие вопросы