Составить программу на языке Паскаль. Просто помогите! Умоляю! 1)Составить программу ввода букв или цифры,или спецзнака. Выводить сообщение типа"Это цифра..."," Это буква..",или "Это спецзнак..". К сообщению добавлять саму цифр...
Составить программу на языке Паскаль. Просто помогите! Умоляю! 1)Составить программу ввода букв или цифры,или спецзнака. Выводить сообщение типа"Это цифра..."," Это буква..",или "Это спецзнак..". К сообщению добавлять саму цифру,букву,спецзнак.
2)У белых на доске остался король,а у черных король и ферзь. Охарактеризовать положение белых с помощью одного из слов шах,мат,пат,обыкновенная позиция
Ответ(ы) на вопрос:
Задача 1, Pascal.ABC.Net
const
sAlpha='abcdefghijklmnopqrstuvwxyzабвгдеёжзийклмнопрстуфхцчшщъыьэюя';
sDigit='0123456789';
var
c,c1:char;
begin
Write('Введите символ: '); Readln(c);
c1:=LowerCase(c);
if Pos(c1,sAlpha)>0 then Writeln('Введена буква ',c)
else
if Pos(c1,sDigit)>0 then Writeln('Введена цифра ',c)
else Writeln('Введен спецсимвол ',c)
end.
Программирование задачи №2 - большая работа, требующая многих часов, если не имеется готовых наработок для программирования шахматной игры. Давать подобные задачи для решения на данном Сервисе - бесполезное занятие, такое не задают даже на олимпиадах.
Не нашли ответ?
Похожие вопросы