Составить программу, по которой выводится таблица кодировки с русскими буквами и кодами. В программе Паскаль. Помогите, пожалуйста.

Составить программу, по которой выводится таблица кодировки с русскими буквами и кодами. В программе Паскаль. Помогите, пожалуйста.
Гость
Ответ(ы) на вопрос:
Гость
var   i,n:integer;   s:string;   a:array[1..32,1..2] of string; begin   n:=1;   for i:=Ord('А') to Ord('Я') do   begin     Str(i,s);     a[n,1]:=Chr(i)+' - '+s;     Inc(n);   end;   n:=1;   for i:=Ord('а') to Ord('я') do   begin     Str(i,s);     a[n,2]:=Chr(i)+' - '+s;     Inc(n);   end;   for i:=1 to 32 do writeln(a[i,1],'   ',a[i,2]) end.   Результат выполнения программы в среде PascalABC.Net А - 192   а - 224 Б - 193   б - 225 В - 194   в - 226 Г - 195   г - 227 Д - 196   д - 228 Е - 197   е - 229 Ж - 198   ж - 230 З - 199   з - 231 И - 200   и - 232 Й - 201   й - 233 К - 202   к - 234 Л - 203   л - 235 М - 204   м - 236 Н - 205   н - 237 О - 206   о - 238 П - 207   п - 239 Р - 208   р - 240 С - 209   с - 241 Т - 210   т - 242 У - 211   у - 243 Ф - 212   ф - 244 Х - 213   х - 245 Ц - 214   ц - 246 Ч - 215   ч - 247 Ш - 216   ш - 248 Щ - 217   щ - 249 Ъ - 218   ъ - 250 Ы - 219   ы - 251 Ь - 220   ь - 252 Э - 221   э - 253 Ю - 222   ю - 254 Я - 223   я - 255
Не нашли ответ?
Ответить на вопрос
Похожие вопросы