Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные?
Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные?
Ответ(ы) на вопрос:
Var
x,ed,des,sot:integer;
Begin
Readln(x);
ed:=x mod 10;
des:=x div 10 mod 10;
sot:=x div 100 mod 10;
x:=0;
if sot mod 10=1 then x:=x+0 else x:=x+1;
if des mod 10=1 then x:=x+0 else x:=x+1;
if ed mod 10=1 then x:=x+0 else x:=x+1;
if x>0 then writeln('Есть') else writeln('Нет');
end.
var
n,d1,d10,d100:integer;
begin
Write('Введите натуральное трехзначное число: '); Read(n);
d1:=n mod 10; d100:=n div 100;
d10:=(n div 10) mod 10;
if (d1 mod 2 = 0) or (d10 mod 2=0) or (d100 mod 2=0)
then Writeln('Есть четная цифра')
else Writeln('Нет четных цифр')
end.
Не нашли ответ?
Похожие вопросы